APEER Module Debugger: invalid volume specification

Hi,

I’m trying to get an APEER module to run locally on my machine inside of a Windows Docker container. I have already tested the module on APEER using a Linux Docker container both locally and on the cloud, and it worked fine. However, when I try to run it in a Windows container, I get the following error:

Running module ...
docker: Error response from daemon: invalid volume specification: 'C:\Users\U6ARGILL\Desktop\apeer_test\local_bscan_test\output:/output'.
See 'docker run --help'.

module run failed

The Dockerfile looks like this:

FROM python:3.7.2-windowsservercore-1803

WORKDIR /usr/src/app
COPY requirements.txt .
RUN pip install --no-cache-dir -r requirements.txt
COPY apeer_main.py .
COPY oct_classification_crypt.py .
COPY module_specification.json .
COPY OCT_input.pb .
ENTRYPOINT [ "python3", "./apeer_main.py" ]

I have already tried adding ENV COMPOSE_CONVERT_WINDOWS_PATHS=1 to the Dockerfile, but it didn’t help.

If I switch Docker to use Linux containers and change the base container image to:
FROM python:3.6
the module runs fine.

I enabled filesharing when using Linux Docker containers, because that was causing an issue, but there doesn’t seem to be a setting for filesharing when using Windows containers.

The main problem seems to be that the mounted output drive that the APEER Module Debugger creates is using a forward slash, as if it is using a Linux container:

C:\Users\U6ARGILL\Desktop\apeer_test\local_bscan_test\output:/output
____________________________________________________________ ^

I’m currently out of ideas. Any help would be appreciated.